Powered By Blogger

Friday, December 21, 2012

Increasing filesystem space on AIX


Increasing filesystem space on AIX

To check all filesystems:

# df -g

# lslv test (Name of the logical volume)
This will give volume group name

# lsvg rootvg (Volume group name)

Verify free PP and if we have enough space than

# chfs -a size=+1G /filesystem

It will add 1 GB to the filesystem

# df -g (Verify filesystem)






Wednesday, October 31, 2012

Make sendmail on Solaris listen to more than localhost

Check the current configuration:

# svcprop sendmail grep -i local_only
  config/local_only boolean true
# svccfg -v -s sendmail setprop config/local_only=false
# svcadm refresh sendmail # svcadm restart sendmail



Monday, August 20, 2012

Excluding directories and files in tar command

Create a file with all the dictories and files  that you want to exclude in the tar

# less exclude
 test1

 hello

Execute following command

# tar -cvfX test.tar ./exclude *
a hello excluded

a test/ 0K
a test1 excluded
a test2/ 0K
a test3/ 0K


Extract with tar as usual

# tar -xvf test.tar

 

Thursday, July 5, 2012

Setting UP private interface between two zones:


        Setting UP private interface between two zones:

1)      Connect two physical server using cross over cable
2)      ifconfig nxge3 inet 192.168.0.10 netmask 255.255.255.0 broadcast 192.168.0.255
3)      ifconfig nxge3 up
4)      Make changes to the zone so that it will persistent
bash-3.00# zonecfg -z zone
zonecfg:testzone> add net
zonecfg:testzone:net> set address=192.168.0.15
zonecfg:testzone:net> set physical=nxge3
zonecfg:testzone:net> end
zonecfg:testzone> verify
zonecfg:testzone> commit
zonecfg:testzone> exit

5)      Create interface and attach to the zone from the global
# ifconfig nxge3 addif 192.168.0.15 netmask 255.255.255.0 broadcast 192.168.0.255 zone testzone up
Created new logical interface nxge3:1

Oracle settings in /etc/project


/etc/project

 

Command to check value for project.max-shm-memory

prctl -n project.max-shm-memory -i project user.oracle

Command to increase memory to 96 GB memory for running Process

prctl -n project.max-shm-memory -r -v 96GB -i project user.oracle

Command to Make it permanent by updating /etc/project file

projmod -sK "project.max-shm-memory=(privileged,103079215104,deny)" user.oracle

Command to check all parameters for current user

prctl $$

Command to check all parameters used for Oracle user

prctl -i project user.oracle


Tuesday, July 3, 2012

Adding Static IP on Solaris 11


Adding Static IP

root@solaris11:~# ipadm create-ip net2
root@solaris11:~# ipadm create-addr -T static -a 192.168.0.235/22 net2/ipv4
root@solaris11:~# route -p add default 192.168.0.254
add net default: gateway 192.168.0.254
add persistent net default: gateway 192.168.0.254

updating /etc/resolv.conf on Solaris 11


### updating /etc/resolv.conf on Solaris 11 ################
root@solaris11:~# svccfg
svc:> select dns/client
svc:/network/dns/client> setprop config/search = astring: ("search.com" "searchme.com" "searchyou.com")
svc:/network/dns/client> setprop config/nameserver = net_address: (192.10.10.10 192.10.10.11 192.10.10.12)
svc:/network/dns/client> select dns/client:default
svc:/network/dns/client:default> refresh
svc:/network/dns/client:default> validate
svc:/network/dns/client:default> select name-service/switch
svc:/system/name-service/switch> setprop config/host = astring: "files dns"
svc:/system/name-service/switch> select system/name-service/switch:default
svc:/system/name-service/switch:default> refresh
svc:/system/name-service/switch:default> validate
svc:/system/name-service/switch:default>
svc:/system/name-service/switch:default>
svc:/system/name-service/switch:default>
svc:/system/name-service/switch:default>
svc:/system/name-service/switch:default> exit
root@solaris11:~# svcadm enable dns/client

Thursday, June 21, 2012

Stopping and Starting Ops Center 12c

Stopping Ops Center 12c

# /opt/SUNWxvmoc/bin/proxyadm stop -wv
# /opt/SUNWxvmoc/bin/satadm stop -wv

Starting Ops Center 12c

# /opt/SUNWxvmoc/bin/satadm start -wv
# /opt/SUNWxvmoc/bin/proxyadm start -wv

Installing IDR on solaris 11

Installing IDR on solaris 11 is different from Solaris 10 (patches). They called it idr (interim diagnostic relief) indentifier on Solaris 11

Following example, I am installing idr111 on Solaris 11 server

# pkgrepo create /var/tmp/idrrepo


# cd /var/tmp

# pkgrecv -s ./idr111p5p -d /var/tmp/idrrepo '*'

# pkg set-publisher -g file:///var/tmp/idrrepo solaris

# pkg publisher ( To verify that publisher is available)

solaris (non-sticky) origin online file:///var/tmp/idrrepo/


Install the idr using following command:

# pkg install idr111


Verify the package is installed by


# pkg verify -v idr111

PACKAGE STATUS

pkg://solaris/idr111 OK

Wednesday, June 20, 2012

Error while luactivate

/usr/sbin/luactivate: /etc/lu/DelayUpdate/: cannot create

Workaround:
execute folloing:

# export BOOT_MENU_FILE="menu.lst"

Debugging issues on Solaris using truss

In original ksh terminal, find out the PID of the ksh shell:


# ps

On 2nd terminal:

# truss -faeldo locale.truss -vall -r0 -w 1,2 -p (PID of ksh shell)

In original ksh terminal:

Execute the command which is having issues

On 2nd terminal:


Tail the locale.truss or read the contents for more details




Tuesday, April 10, 2012

Modules of Cloud

There are basically three service modules in the cloud computing:

1) SaaS -> Software as a Service, Providers will provide the client with a complete software application environment, including management and the user interface. Clients usually have access to the environment through a thin user interface such as browser, which enables data entry and manages user interactions. Provider must manage everything else, from the infrastructure to the architecture.

2) PaaS -> Platform as a Service, provides clients with the complete development environment incuding virtual machines . operating systems, applications, services. Clients can deploy their own applications programmed using PaaS-compatible languages and tools. With this model, the service provider is responsible for managing cloud infrastructure and the operating systems, and client develop, install and manage the applications they want to deploy.

3) IaaS-> Infrastructure as a Service provides hardware assets to clients, who can then provision themm. Example of these hardware assets are virtual computing systems, storage resources.Clients are responsible for deploying and managing all the other aspects of the infrastructure including Opeations sytstem, application and user interactions with the systems.

Tuesday, February 28, 2012

Working on extents on Redhat LVM

If you want to create Logical volume using extents:

By default PE size for volume group is 4 MB.


PE Size 4.00 MiB

If you want to change it, you can use -s option when you are creating volume group

For example

# vgcreate -s 8 helloguruvg /dev/sdh

For now, i am using default value which is 4 MB.

I am creating Logical volume with 30 extents (which will be 30 x 4 MB size)

[root@kumar ~]# lvcreate -l 30 -n hellogurulg helloguruvg

Making ext4 filesystem:

[root@kumar ~]# mkfs.ext4 /dev/mapper/helloguruvg-hellogurulg

[root@kumar ~]# mkdir /hellogurufs

[root@kumar ~]# mount /dev/mapper/helloguruvg-hellogurulg /hellogurufs

[root@kumar ~]# df -h

/dev/mapper/helloguruvg-hellogurulg 117M 5.6M 105M 6% /hellogurufs

Edit the fstab to make it persistent

Adding SWAP on Redhat using LVM

Following steps to add swap using LVM with out creating new partition

1) Check if you have enough space in the volume group

[root@kumar ~]# vgs
VG #PV #LV #SN Attr VSize VFree
test1VG 1 4 0 wz--n- 1020.00m 36.00m
testingextentvg 1 1 0 wz--n- 104.00m 24.00m
vgexttest 1 1 0 wz--n- 96.00m 32.00m


Following command will create Logical volume swaphello with the size 10 MB

[root@kumar ~]# lvcreate -L 10M -n swaphello test1VG

[root@kumar ~]# mkswap /dev/mapper/test1VG-swaphello

[root@kumar ~]# swapon /dev/mapper/test1VG-swaphello

Add swap entry in the fstab so that it will be persistent

[root@kumar ~]# vi /etc/fstab
/dev/mapper/test1VG-swaphello swap swap defaults 0 0

Check your work

[root@kumar ~]# free -m
[root@kumar ~]# swapon -s

Wednesday, February 15, 2012

chown on solaris 10 (Not owner error)

By default only root can change ownership on Solaris 10 (Even owner of the file can't change it)

If you want owner of the file/directory to update the owner:

Update the /etc/system with the following and reboot
rstchown=0

or

Following if you want to change (Enter commands in the RED) with out reboot (It is not persistent)



# adb -w -k /dev/ksyms /dev/mem
physmem 3ee50a8
rstchown/D
rstchown:rstchown: 1
rstchown?W0x0
rstchown: 0x1 = 0x0
rstchown/D
rstchown:rstchown: 0
Welcome to the UNIX world