Powered By Blogger

Wednesday, March 25, 2009

Command to check open ports

/usr/local/bin/lsof -P -z -i 2>/dev/null grep global grep LISTEN grep -v localhost

Note: There is a pipe before grep and after null. Somehow it is not printing in the output

Adding Disks To Zpool

Re-scan the HBA, then create new disk device nodes:
cfgadm -c configure c5 ; devfsadm -C -v
Have a look to see if the disks actually showed up:
format
Look at the new disk device nodes:
ls -latr /dev/rdsk/*s2 grep "Oct 24"
...and let's just print the Solaris disk devices for use in the next step:
ls -latr /dev/rdsk/*s2 grep "Oct 24" awk '{print $9}'
Finally, add the disks to the pool:
zpool add ZPool-Name c5t60060480000190100665533032323438d0 \ c5t60060480000190100665533032323338d0 \ c5t60060480000190100665533032323238d0 \ c5t60060480000190100665533032323138d0 \ c5t60060480000190100665533032323038d0 \ c5t60060480000190100665533032314638d0 \ c5t60060480000190100665533032314538d0 \ c5t60060480000190100665533032314438d0 \ c5t60060480000190100665533032314338d0 \ c5t60060480000190100665533032314238d0 \ c5t60060480000190100665533032314138d0 \ c5t60060480000190100665533032313938d0 \ c5t60060480000190100665533032313838d0 \ c5t60060480000190100665533032313738d0 \ c5t60060480000190100665533032313638d0 \ c5t60060480000190100665533032313538d0
And admire our handiwork:
zpool status Zpool-name
zfs list grep Zpool-name

How To Log Into E-25K

ssh -l (user-id) (system-control)

sudo su - (Sudo to root)

su - sms-svc (login to user who have access to system control)

(system-control)-sc0:sms-svc:1 > showplatform (useful commands)

(system-control)-sc0:sms-svc:1 > showboards (useful commands)

console -d [ ABC ] (login to domains)

NOTE: The escape character is "~."

Controlling Weblogic Admin Server with Solaris SMF

--> Create Admin.xml under /var/svc/manifest/application/management :
--> in /etc/security/auth_attr, add (as root):
solaris.smf.manage.Admin/weblogic:::Admin Management::
--> and then run the usermod command (as root):
usermod -A solaris.smf.manage.Admin/weblogic weblogic
--> Run following to validate :
svccfg validate Admin.xml
--> Run following to import :
svccfg import Admin.xml
--> Checking status :
svcs -agrep weblogic
--> Enable it :
svcadm enable Admin/weblogic:default
--> Disable it
svcadm disable Admin/weblogic:default

Monday, March 23, 2009

format c20t60060480000190100665533032354438d0 (To verify disk layout)
metainit d151 1 1 /dev/rdsk/c20t60060480000190100665533032354438d0s0 (To create Meta Device)
newfs -i 8192 /dev/md/rdsk/d151 (To create new filesystem
mkdir /u039 (create a directory)
vi /etc/vfstab (Enter information in vfstab)
mount /u039 (Mount the filesystem)
zpool create c4t60060480000190100665533030394138d0
zfs set mountpoint=none
zfs create /apps
zfs create /homer
zfs destroy /homer
zfs create /home
zfs set zoned=on /apps
zfs set zoned=on /home
zfs create /dev
zfs set zoned=off /apps
zfs set zoned=off /home
zfs rename /apps /dev/apps
zfs rename /home /dev/home
zfs set quota=2G /dev/apps
Welcome to the UNIX world